aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorAUTOMATIC <16777216c@gmail.com>2023-05-10 09:02:23 +0300
committerAUTOMATIC <16777216c@gmail.com>2023-05-10 09:02:23 +0300
commit4b854806d98cf5ccd48e5cd99c172613da7937f0 (patch)
treed4126545441e5b25fbb8aa19011499408d320e17 /pyproject.toml
parentf741a98baccae100fcfb40c017b5c35c5cba1b0c (diff)
F401 fixes for ruff
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml9
1 files changed, 5 insertions, 4 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 9caa9ba2..0883c127 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,13 +1,14 @@
[tool.ruff]
+target-version = "py310"
+
exclude = ["extensions"]
ignore = [
- "E501",
-
- "F401", # Module imported but unused
+ "E501", # Line too long
+ "E731", # Do not assign a `lambda` expression, use a `def`
]
[tool.ruff.per-file-ignores]
-"webui.py" = ["E402"] # Module level import not at top of file \ No newline at end of file
+"webui.py" = ["E402"] # Module level import not at top of file